Back to overview
Degraded

Support Response Delays

Mar 02 at 03:26pm CET
Affected services
Cloud-IAM Dashboard

Resolved
Mar 02 at 03:51pm CET

The issue affecting our support tool has been resolved.
Response times are now back to normal. Thank you for your patience.

Created
Mar 02 at 03:26pm CET

We are currently experiencing an issue with our support tool, which may cause delayed responses.
Our team is working to resolve this as quickly as possible. Thank you for your understanding.